杨培文

易语言之路

入坑之前,我只会玩游戏开挂,当时还是小学的时候,玩冒险岛,那时候我就会用CE(Cheat Engine)这样的软件来修改游戏数据,冒险岛这个游戏是靠打怪升级为乐趣的,如果有一款外挂能帮你把怪物定在一个点(吸怪),那么这个外挂就十分有价值.如下图:

(图片来自网络)

其实原理很简单,获取到屏幕的左右上下之后,修改为一个点就可以让怪物集中在一个点.当时除了CE这样的工具之外,还出现了用易语言写的一键傻瓜型外挂.这种程序通常写得很简陋,里面通常是一些按钮,偶尔还带一点编辑框.当时我就下了这样的外挂尝试,效果还不错.有一次出现了一个非常厉害的外挂,好像是类似于无敌之类的.就是怪物碰你你不会损失生命值.这样的挂给我们带来了巨大的诱惑力.但是我在网上下载了一个程序之后,提示了类似于这样的信息:

,然后下载了易语言…

下下来之后,我发现,哈,我可以创建窗口!我可以放按钮在上面!我还可以balabala……那个外挂后来发现只是少了一个文件,下下来就好了.不过编程之路就从这里开始踏下了第一步.为什么不学C!小学根本不会英文啊..

从初中开始,就陆陆续续地做过了一些奇葩玩意.比如为了刷某网页访问量做的自动刷新(当时既不会HTTP操作也不会线程,就用时钟周期事件和超文本浏览框来刷),当时还在网吧里的地下一层开了所有的机器打开我的程序来刷,想想也挺牛的.软件大致结构就象这样:

这里面真的有16个浏览器…

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24

.版本 2
.支持库 HtmlView

.子程序 _时钟1_周期事件
.局部变量 地址, 文本型

地址 = “http://ypw.ys168.com”
超文本浏览框1.地址 = 地址
超文本浏览框2.地址 = 地址
超文本浏览框3.地址 = 地址
超文本浏览框4.地址 = 地址
超文本浏览框5.地址 = 地址
超文本浏览框6.地址 = 地址
超文本浏览框7.地址 = 地址
超文本浏览框8.地址 = 地址
超文本浏览框9.地址 = 地址
超文本浏览框10.地址 = 地址
超文本浏览框11.地址 = 地址
超文本浏览框12.地址 = 地址
超文本浏览框13.地址 = 地址
超文本浏览框14.地址 = 地址
超文本浏览框15.地址 = 地址
超文本浏览框16.地址 = 地址

之后我的第二次启蒙来源于一个效率非常高的刷QQ空间人气的软件.那软件一秒居然可以访问50次.我的天当时那个单核的时代他一秒50次简直颠覆了我的世界观.后来我看了他的源码之后知道了线程这么个概念,知道了HTTP这个概念(原来以为必须要浏览器啊).同时还学会了POST.学会了利用WPE截包(现在才发现chrome截包方便太多).

下面是我做的一些小工具: QQ空间数据查看—-查看你的空间访客量多少,有多少阳光指数,爱心指数,balabala….(数据挖掘啊)(2009年7月15日) 空格点鼠标—-当时估计是觉得鼠标不好用,然后用空格键代替点鼠标(键盘热键和鼠标模拟)(2009年7月19日) 柯南音乐播放器—-当时在某站找到一个网盘,然后把我搜刮的柯南音乐全部上传上去了,做了一个小播放器(2009年8月3日)

SOSO刷搜索次数—-刷到了世界第一的神器(2009年10月18日)

4399刷签到—-为了无聊的分数,弄了一个每天自动签到的后台程序(插入启动项,杀毒白名单,可怕)(2009年8月4日)

全能(ALL)—-一款可以登录QQ,测试GET和POST的软件,可以连续发送(多线程),可以转码,内置浏览器方便登录,支持代理IP.(2010年1月2日)快速测试HTTP神器啊…现在还在用它

QQ牧场激活器—-当时QQ农场和QQ牧场是两个东西,牧场不是所有人都能玩,但是我们发现了一个漏洞,所以就做了这么个玩意(2010年1月24日)

密保卡安全浏览器—-这是玩腾讯游戏的时候避免别人拍照而做的软件..没什么特别的,大家应该看明白了.

QQ炸弹—-正如这个神奇的名字,它就是用来炸QQ好友的,自动生成英文/数字/甚至是中文,自动输入并发送,可调时间间隔(可怕的科技)(2010年4月19日)

占用内存程序—-正如这个名字…它没有任何用处,就是为了占内存.(2010年6月10日)

QQ拼音刷打字记录程序—-没错拉,键盘模拟打字而已,可以把每日打字量刷非常高(2010年7月1日)

刷化肥—-这个软件应该是当时QQ农场牧场第一个外挂吧..(2014年7月31日),利用腾讯服务器时间不同步的漏洞,可以在0点领翻倍数量的化肥,并且有黄钻用户领到了几万袋化肥(人民币价值几十万),成功成为当时排行榜前几名.也是一个传奇了.

自动种植—-QQ农场自动利用刷来的化肥种植农作物,收割,铲除,多线程异步刷等级,曾经一天刷了将近一百级(2010年8月3日)下图为8月5日,下下图为10月31日

犇牛病毒专杀工具—-当时不知道为什么中毒了,电脑各个地方都是usp10.dlllpk.dll,于是写了一个工具全盘搜索该文件删除.(2010年8月17日)

抢黄钻—-这玩意简直是抢火车票的祖先..自带帐号记录,北京时间,多线程刷分,当时搞活动可以领黄钻,但是只有特定时候开放,于是我就写了个这个软件,到点了马上开线程刷,一定能领到,没有人比一秒50次的加特林还快了.(2010年9月5日)

(注:程序的北京时间经过修改,原来使用的授时中心的时间源已经404了) 附上时间校对的程序(甚至考虑了东八区UTC+8):

1
2
3
4
5
6
7
8
9
10
11

.版本 2

.子程序 校对
.局部变量 second, 整数型
.局部变量 a, 文本型

a = 彗星HTTP读文本 (“http://open.baidu.com/special/time/”)
输出调试文本 (a)
second = 到长整数 (取文本中间内容 (a, “baidu_time(”, “)”)) ÷ 1000
SJ = 增减时间 (到时间 (“1970.01.01 08:00:00”), #秒, second)

强制关机程序—-这个有点厉害,调用系统API提权强制黑屏关机(2010年10月17日)

1
2
3

RtlAdjustPrivilege (#SE_SHUTDOWN_PRIVILEGE, 1, 0, 0)
NtShutdownSystem (#SHUTDOWN)

bilibili视频地址获取器—-没想到吧!当时我居然做出来了这么神奇的玩意,用来下视频的(2010年11月1日)当时的视频地址长这样:http://bilibili.us/video/av34026/,现在已经失效.

Q宠大乐斗辅助—-这个功能就十分强大了,几乎把一个游戏的每日操作做得半自动化了,比如自动刷牧场(这是个漏洞,牧场有个拍蚊子功能,我直接把POST数据改为num=100了,这样一天得到的经验值就满了),然后还有自动浇花(花藤),好友列表双击PK,领取各种每日奖励.(2010年11月22日)

QQ农场牧场辅助工具—-依然是一系列的全自动操作,免除各种烦恼.(2010年11月25日)原理都一样,不再细说.

独立钻石棋—-没错!我做过游戏!非常简单的一个棋类游戏,规则可以自行百度.(2010年11月30日)

百度一系列工具—-百度登录,百度注册,百度扫号,刷粉器,掌上百度发帖爆吧器.还带有权限验证功能.恐怖到自动获取代理IP.(这时候我就会正则表达式了)(2011年2月19日)

批量创建QQ群—-可以创建出连号QQ群来卖!可以批量登录QQ,带有cookies管理!(意味着你可以同时有一百个QQ号在一个软件上登录)(2011年4月17日)

键盘记录器—-而且还写了配套回放软件…记录了键值,按下还是弹起,距离上次操作的间隔时间,可以完全回放出来.(2011年8月28日)

远程手机攻击器—-是短信轰炸的那种攻击,远程就是放在服务器上面的那种.可以远程下指令给服务器让服务器短信轰炸手机.发短信的方式是利用某网站搞活动,验证手机号码会发送短信,但是没有限制次数.(2012年1月9日)

高考倒计时—-哈哈哈 就是高考倒计时拉,我后来居然还用单片机做了一个真正的高考倒计时装置,然后被班主任没收了.(2012年6月17日)中间时间跨度好大,因为我犯事了,所以好像半年没有碰电脑.

这里有一个大事—-不能说(2013年10月)

BTBU上网登录—-给学生们上网登录的软件(2013年10月14日)

BTBU免流量软件—-顾名思义,SSL-VPN不多解释(2013年11月14日)

素数螺旋图的绘制—-具体定义请维基百科,这只是个人兴趣,GEEK向(2013年11月14日)

眨眼识别—-这个碉堡了,这是脑电波识别,但是我水平不够,就做了个眨眼识别(2014年1月29日)

透传—-这是给我的wifi插座做的服务器端,透明传输(2014年3月24日)

BTBU录入—-懂的人懂,这个不能说(2014年3月30日)

机器鱼代码更新工具—-自动替换api的文本处理工具,临时性工具(2014年5月21日)

DHT11远程温湿度监控系统—-某爱德课设作品,远程监控温湿度,温度条显示(2014年6月18日)

雾霾查看器—-这个就是利用了气象局的信息做的临时小创意(2014年7月31日)现在他们自己服务器好慢.

mini3—-这又是一个不能说的程序(2014年12月2日)

BTBU VPN连接器—-这是连接学校VPN的小工具,由于有些学生电脑本身是WIN8的系统,又升级了IE,导致VPN连不上,所以做了这么个工具(发出来没几天学校就改版了VPN,把域名换了)(2015年1月17日)

未完待续…